WordPress 3.2 is going to be released very soon, make sure you meet the minimum requirements: PHP 5.2.4 and MySQL 5.0.

Also support for IE6 has been dropped.